Using PINsafe Log Viewer Version 2
The log viewer (LogViewer) is designed to make it easier to view and analyse PINsafe event logs.
Requirements
This program requires Windows XP or later, and Microsoft.Net framework version 3.5 or later.
Installation
To install the log viewer, simply run setup.exe from the download package and follow the wizard instructions.
Starting LogViewer
You can start LogViewer from the PINsafe Log Viewer menu created on installation. On startup, you will see an empty form as below:
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To open a log file, click the “Open File” button, select “Open” from the File menu, or simply press Ctrl+O. You will be presented with a familiar file dialog from which to select a file to open. Once you have selected a file, it will be opened, and the log file will be displayed as below:
[image: ]
[bookmark: _GoBack]You can also open files by dragging and dropping them on the LogViewer window, or by specifying the file name as an argument to the LogViewer command line. You can also import events by pasting them into a file window, as explained later.
You can also open multiple files, at once or one at a time.
The Log File Window
As you will see, each file you open creates a new window with two tabs on it. The Events tab displays the log events in a grid. You cannot modify the events here, but you can select one or more events – see later for more information. The Text tab displays the event log as raw text. This text can be edited, but any changes you make will not be reflected in the Events tab unless you re-parse the log (see below for more information). You can also paste events from another window, or from an external source. To make this more convenient, you can create a new, empty window to paste into using the File New menu option. See below for more information.
Features
Exporting Data
You can export individual events, or an entire file, either to a file on disk or to the clipboard, in a number of different formats.
To open the Export dialog, select Export from the File menu, click the Export button at the bottom of the main form, or press Ctrl+X. The export dialog looks like this:
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The two radio buttons allow you to export all events in a file, or only the selected ones. If no events are selected, the second button is disabled.
The buttons at the bottom allow you to save the events to a file, in which case a save file dialog is displayed for you to enter the file name, or to the clipboard, in which case you can paste them into another application.
The drop-down list in the centre allows you to select the format of the exported data, as follows:
· PINsafe log – XML events, in the same format as used by PINsafe.
· XML file – as above, with additional XML tags top and bottom to make this a complete XML document.
· Tab-separated text – each event on a new line, with individual fields separated by tab characters. This is probably the best format for importing into spreadsheet applications.
· Comma-separated text – as above, except that fields are separate by commas, and contained within quotation marks.
· HTML table – each event is contained within a table row, each field being a cell. The entire content is contained within table tags.
· HTML page – as above, except that additional HTML tags are added to make a complete HTML page.
For convenience, two options are available as single menu items: export to clipboard as PINsafe log items or tab-separated text are available from the Edit menu, or as shortcut keys Ctrl+C and Ctrl+T respectively.
Select Columns
This option allows you to select which columns are displayed in the event viewer. It can be selected from the View menu, using the Select Columns button at the bottom of the main form, or using the shortcut Ctrl+L.
The Select Columns dialog looks like this:
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The following columns are available to display:
· Timestamp – the time and date at which the event took place
· Level – the severity level of the event: Debug, Info, Warn, Error or Fatal. Debug messages are stored in separate files (debug.log), and only if debug is enabled.
· Message – the actual content of the event message – probably the most important part of it.
· Source – the remote location which caused the event. For scheduled events and events caused by the administration console this will be empty.
· Stack Trace – some error messages will include detailed information as to where within the PINsafe code the error occurred. Useful for troubleshooting.
· Thread – the execution thread in which the event occurred.
· Ndc – the PINsafe class in which the event occurred.
· TimestampAsLong – the timestamp as a single long number, as it is stored in the event log.
By default, only the first three columns are displayed for a newly-opened event file. If the column list is changed, the next file opened will reflect the most recent column selection. This setting is not saved between sessions.
On opening the form, the selected columns always reflect the visible columns in the current active window, if any, or else the last selected columns if no file is open. On clicking Update, the column selection is applied to the current active window only, by default. If, however, “Apply to all files” is checked, then the current column selection is applied to all open files.
Finding Events
To find events containing a specific sub-string, use the Find form, available from the View menu, the Find button at the bottom of the main menu or the shortcut Ctrl+F.
This form is very simple:
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Enter the text to search for and click Find. Only the message column is searched. Searches are always case-insensitive.
The search always starts from the current event on the current active window. Subsequent Finds will search for further events within the active window. When the end of the file is reached, all other open files are searched in order.
Keep the find form open while searching: if you close the form, the previous search is forgotten and searching will start once again from the current selection.
Filtering Events
To restrict which events are displayed, select Filter from the View menu, the Filter button from the bottom of the main form, or use the shortcut Ctrl+I. The Filter form is shown here:
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Events can be filtered by three criteria: by date/time range, by level or by message content. You can combine these three criteria if required. Events are only displayed if they meet all the selected criteria.
To filter by date, check the Starting or Ending date checkbox (or both), then click the Date link to display a dialog from which to select the date and time. You can specify only the start date, only the end date, both or neither. Note that when entering dates, although the month is shown by name, it must be entered by number, so to select February, for example, enter “2”. Alternatively, use the calendar drop-down.
To filter by level, select the desired level, and choose to display only the selected level, or that level or higher. So, for example, if you select Warn or higher, Warn, Error and Fatal events are shown.
To filter by message content, enter the text to search for, and select from the drop-down to display events that contain the entered text anywhere, that start with the entered text, or that do not contain the entered text. By default, the text searched is case-insensitive, but you can choose to make it case sensitive by checking the appropriate option.
Click Apply to filter the events according to the specified criteria. This does not close the dialog box, so if the filter you applied does not have the required effect, you can adjust it. Click Close to close the dialog (the filter still applies).
To remove any applied filter, and show all events, click Show All.
By default, the filter only affects the active file. However, checking the “Apply to all files” box will apply the filter to all open files. Newly-opened files will not, however, be affected by any filter: all events will be shown. On opening the filter dialog, the displayed filter will always reflect the filter from the active file.
Sorting Events
To sort events within a file, select Sort from the View menu, click the Sort button at the bottom of the main form, or use the shortcut Ctrl+S. The sort form looks like the following:
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You can sort only by the first three columns: Timestamp, Level and Message, irrespective of which columns are displayed. You can apply up to three sort criteria, and each can be ascending (default) or descending.
As with previous features, by default the sort criteria apply only to the active file. To sort all files, check the “Apply to all files” box. On opening the dialog, the displayed criteria reflect the sort currently applied to the active window.
Menu Reference
File Menu
New (Ctrl+N): opens a new, empty log viewer window. The contents of the current clipboard, if any, are automatically pasted into the text tab, and the result parsed. If the clipboard does not contain valid PINsafe log events, the Events tab will remain empty.
Open (Ctrl+O): displays a file dialog from which you can select one or more log files to open in the LogViewer. If any file you attempt to open is not a valid pinsafe log file, the text content will be displayed in the Text tab, but the Events tab will be empty. This operation can also be executed from the Open File button at the bottom of the main form.
Open Directory (Ctrl+D): displays a directory dialog from which you can select a directory containing PINsafe log files. All files in the directory will be imported: as above, if any are not valid PINsafe log files, only the text will be displayed.
Close (Ctrl+F4): closes the currently active file.
Close All (Ctrl+Shift+F4): closes all open files.
Close all but this (Shift+F4): closes all open files except for the active one.
Export (Ctrl+X): opens the Event Export dialog. This allows you to export either all events or just selected events to various formats, either as a file, or to the clipboard. This option is described in more detail above. It is also available from the Export button at the bottom of the main form.
Exit (Alt+F4): closes the application.
Edit Menu
Copy as log (Ctrl+C) : Copies the selected events from the active window, or all events if none are selected, to the clipboard in PINsafe log format.
Copy as text (Ctrl+T): Copies the selected events from the active window, or all events if none are selected, to the clipboard in tab-separated text format. This is the most convenient format for pasting into spreadsheet applications.
Paste (Ctrl+V): Pastes the contents of the clipboard into the Text tab of the active window. Also automatically parses the text (see next entry).
Parse (Ctrl+P): Parses the content of the Text tab from the active window and displays the result in the Events tab. If the Text tab does not contain valid PINsafe log events, the Events tab will be empty.
View Menu
Select Columns (Ctrl+L): Choose which information from the event log is displayed on the Events tab. A new file is always opened with Timestamp, Level and Message enabled, which are the most useful pieces of information. More information on the Choose Columns dialog is given above. This operation is also available from the Select Columns button at the bottom of the main form.
Find (Ctrl+F): Search for specified text within the Message entries of the event log. This option is described in more detail above. This operation is also available from the Find button at the bottom of the main form.
Filter (Ctrl+I): Restricts which events are displayed according to various criteria. More information on the Filter dialog is given later. This operation is also available from the Filter button at the bottom of the main form.
Sort (Ctrl+S): Sorts the events according to specified criteria. More detail on this operation is given later. This operation is also available from the Sort button at the bottom of the main form.
Show Decimal Seconds: Toggles whether the Timestamp column shows time truncated to seconds or to milliseconds.
Window Menu
The first three options on this menu allow you to arrange the file windows tiled horizontally or vertically, or cascaded. The remaining options show the open files, allowing you to activate them.
Help Menu
Help (F1): displays the help dialog, which is essentially the information given in this document.
About: displays details of the program.
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Date/Time. Level  Event

26/05/201108:16:20 Database Manager stated
26/05/201108:1620 (Connection Pool Manager stated
26/0/2011 081621 User repostory manager stated

26/0/2011 081621 Migration Manager started

26/0/2011 081621 Folicy configuration registered

26/0/2011 081621 Messaging corfiguration registered.
26/0/2011 081621 Thid party manager stated.

26/0/2011 081621 Peer manager sated.

26/0/2011 081621 AgentXVIL managerstated

26/0/2011 081621 Regenerating giyph cache.
26/05/201108:1625 (Giyph cache loaded

26/05/2011 081628 Single channelstore stated.

26/05/2011 081628 [RADIUS server manager started.
26/05/2011 081628 The Session Queue Job has been scheduled
26/05/2011 081628 The Peer Sync Job has been schedued.
26/05/2011 081628 The Inactive User Job has been schedued.
26/05/2011 081628 The Audt Log Ty Job has been scheduled
26/05/2011 081628 The PIN Expiy Job has been schedued.
26/05/2011 081628 The Transport Manager Job hias been schedued
26/05/2011 081628 [Job scheduer stated.

26/05/2011 081628 Mode Manager stated
26/05/201108:16:59 Started a singe channel session
26/05/201108:17.03 Successiullogn
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