User sync stops working
Contents
Overview
This article describes various workarounds available in the event that the either the scheduled User Sync jobs fail to complete or a manual User Sync does not appear to work. The problem can exist at various levels.
For instance, if you notice that just Active Directory is having problems synchronising, or that errors are specific to Active Directory are prevalent then see Active Directory users are not synching.
Alternatively if it is obvious that you are getting no synchronisation output in the Log Viewer whatsoever, then you need to consider taking the actions described in this article.
Prerequisites
- Swivel version 3.7 or lower;
Symptoms
- Issue contained to just one Apache Tomcat instance running PINsafe;
- User sync attempts appear not to work - no additional entries in the PINsafe logs other than a statement that the User Sync has been carried out when an Administrator clicks the User Sync button, or the scheduled sync attempts to run.
Cause
In Swivel versions prior to version 3.8 there was an unhandled exception which caused multiple user sync requests to pile-up on rare occasion. Any subsequent attempt to sync would not be actioned.
Solution
The solution is fairly simple in nature, but consideration needs to be taken where a High Availability Swivel implementation is employed.
Single Swivel instance
- Restart Tomcat to eliminate the issue.
HA Swivel instance
- If using a Virtual IP, stop Heartbeat on the Standby (assuming that the Primary currently holds the Virtual IP);
- Restart Tomcat on the Primary;
- Start Heartbeat on the Standby;
You should find that these solutions will eliminate the issue.
Long Term Solution
It is recommended that you upgrade to a more recent version in order to take advantage of the improved User Sync functionality.